Du hast noch keinen Account? Klicke hier um Dich jetzt kostenlos zu registrieren!

LS 2009 - 2011 Mods Community Foren-Übersicht LS 2009 - 2011 Mods Community

 
 FAQFAQ   SuchenSuchen   MitgliederlisteMitgliederliste   BenutzergruppenBenutzergruppen  RegistrierenRegistrieren 
 ProfilProfil   Einloggen, um private Nachrichten zu lesenEinloggen, um private Nachrichten zu lesen   LoginLogin 


GIANTS_Editor_5.0.1 Zeigt Fehler an Objekten an

 
Neues Thema eröffnen   Dieses Thema ist gesperrt, du kannst keine Beiträge editieren oder beantworten.    LS 2009 - 2011 Mods Community Foren-Übersicht -> Tutorials LS 13
Vorheriges Thema anzeigen :: Nächstes Thema anzeigen  
Autor Nachricht
Manne
Administrator
Administrator


Geschlecht: Geschlecht:männlich
Anmeldungsdatum: 18.04.2010
Beiträge: 4963


Wohnort: BRD-BW-Hohenlohe
Offline

BeitragVerfasst am: 13.10.2012 22:29    Titel: GIANTS_Editor_5.0.1 Zeigt Fehler an Objekten an Antworten mit Zitat

Hallole

Bin am sortieren meiner Map_Modelle um sie mit GIANTS_Editor_5.0.1 für LS13 ready zu machen auf ein Fehler gestoßen : "UVs out of range" [-8,8] Quader002
Der Fehler wird im GE angezeigt unter Scripting.

Durch Google wurde ich auf ein Beitrag von " Stegei " aufmerksam :

-Es sind mit dem LS13 und dem neuen GE nur noch maximal 16 Repetitionen der Textur in einem einzelnen Polygon möglich,
wobei sich die Texturkoordinaten im Bereich -8 bis 8 befinden müssen.
Dies wurde eingeführt auf Grund einer internen Datenstrukturänderung, welche wiederum aus Performance Gründen vorgenommen wurde.
Wir mussten bis auf ein paar Bodenplatten und die Strassen keine Änderungen vornehmen.
Grundsätzlich sieht es eh schlecht aus, wenn man eine Textur zustark wiederholt, da dann alles extrem monoton aussieht.
Anpassen kann man das nur mit Maya, 3DS Max etc. oder direkt im i3d (wobei dies wohl schnell kompliziert wird).
Falls man unbedingt die Textur mehrfach wiederholen will (z.B. für die Strasse oder Bodenplatten), kann man extra Vertices einfügen und diesen dann die Textur auf der anderen Seite von neuem beginnen.
Vielfach bekommt man die Fehlermeldung obwohl man nicht so viele Wiederholungen verwendet.
Dies liegt dann meistens daran, dass man diese nicht um den 0-Punkt zentriert hat. In diesem Fall einfach die UVs um ganze Zahlen verschieben.
Dies ändert das Aussehen nicht, ändert aber die Werte der UVs.

So,nun habe ich den komplizierten Weg gewählt und versuchte den Fehler in der i3d zu Beheben,

Die i3d mit einem txt_editor öffnen und nach dem beschriebenen Fehler suchen (suchfunktion)

<IndexedTriangleSet name="Quader002" shapeId="2">
<Vertices count="52" normal="true" uv0="true">

Durch eine kleine Veränderung wurde der Fehler behoben:

<IndexedTriangleSet name="Quader001" shapeId="1">
<Vertices count="3853" normal="true" uv-0="true">

Durch das minus vor der 0 wurde die Textur an die richtige Stelle auf dem Modell verschoben so das der Fehler im GE nicht wieder kommt,
somit kann man ein Objekt aus LS11 das den Fehler verursacht in LS13 verwenden.
(Die werte können je nach Objekt unterschiedlich sein,man muß die mitte der Textur finden)

Wer will kann es testen am LS11-Farmhaus :buildings/farmHome i3d
Diese Fehler werden im GE angezeigt:
"UVs out of range" [-8,8] farmHomeRoof1
"UVs out of range" [-8,8] farmHomeRoof2
"UVs out of range" [-8,8] farmHomeGround
"UVs out of range" [-8,8] farmHome_LOD
"UVs out of range" [-8,8] farmHomeGround_LOD
"UVs out of range" [-8,8] farmHomeRoof2_LOD
"UVs out of range" [-8,8] farmHomeRoof1_LOD

Durch das minus vor der null ist der Fehler behoben:
<IndexedTriangleSet name="farmHomeRoof1" shapeId="2">
<Vertices count="71" normal="true" uv-0="true" tangent="true">

<IndexedTriangleSet name="farmHomeRoof2" shapeId="3">
<Vertices count="38" normal="true" uv-0="true" tangent="true">

<IndexedTriangleSet name="farmHomeGround" shapeId="5">
<Vertices count="354" normal="true" uv-0="true" tangent="true">

<IndexedTriangleSet name="farmHome_LOD" shapeId="6">
<Vertices count="1462" normal="true" uv-0="true" tangent="true">

<IndexedTriangleSet name="farmHomeGround_LOD" shapeId="7">
<Vertices count="233" normal="true" uv-0="true" tangent="true">

<IndexedTriangleSet name="farmHomeRoof2_LOD" shapeId="8">
<Vertices count="25" normal="true" uv-0="true" tangent="true">

<IndexedTriangleSet name="farmHomeRoof1_LOD" shapeId="9">
<Vertices count="71" normal="true" uv-0="true" tangent="true">


Viel Spass beim ändern der Objekte für LS13.

mfg

Manne

_________________
Qualität braucht Zeit!
Kein Support über PN!

Nach oben
Benutzer-Profile anzeigen Private Nachricht senden Website dieses Benutzers besuchen
Google









BeitragVerfasst am: 13.10.2012 22:29    Titel: Re:


Dein kostenloses Forum -> Super Funktionen, leicht bedienbar, 400+ Styles, schnell einzurichten

Nach oben
Beiträge der letzten Zeit anzeigen:   
Neues Thema eröffnen   Dieses Thema ist gesperrt, du kannst keine Beiträge editieren oder beantworten.    LS 2009 - 2011 Mods Community Foren-Übersicht -> Tutorials LS 13 Alle Zeiten sind GMT + 1 Stunde
Seite 1 von 1

 
Du kannst keine Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum nicht antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.
Du kannst Dateien in diesem Forum nicht posten
Du kannst Dateien in diesem Forum nicht herunterladen





LS 2009 - 2011 Mods Community letztes Thema RSS feed 
Powered by phpBB © 2001, 2005 phpBB Group
Deutsche Übersetzung von phpBB.de

Kostenloses Forum mit Portal, Shoutbox, Album Galerie, Smilies, Styles, Cash » kostenloses phpbb forum

© 2007-2009 phpBB 6 & Gooof.de, ein Kostenloses Forum mit unvorstellbaren Möglichkeiten. kostenloses phpbb forum

Forum-Tools: Impressum - Datenschutzerklärung - Sitemap - Archiv - Portal - Smilie Album
Links: Webtools : Support : Kostenloses Forum : Free Forum : phpBB3 : Gratis-Board : Entdecken web tracker